読者です 読者をやめる 読者になる 読者になる

Windows Home ServerのシステムディスクにWD20EARSを使ってみたら実用に耐えないほど遅かった件

PC WHS

(2011/1/23 その後の追試でWindows Home ServerのシステムディスクにWD20EARSを使っても特にパフォーマンス的に問題ない、という結果が出ています。Windows Home ServerのシステムディスクとしてWD20EARSを使ってみる。(ちゃんと検証編) - yaboratoryの野暮研)



これまでWindows Home Server機にWD10EACSを2台、WD10EADSを2台の計4台のHDDを接続していたのだが、WD20EARSが安くなってきたので、4台⇒2台に容量そのままリプレースしようと思った。

ディスク入れ替えついでに再インストールすることにした。

WD20EARSにWHSインストール

WD20EARSのAdvanced Format TechnologyはWindows XPで使うにはひと手間必要。Windows Home Serverも当然同様の影響を受ける。

Windows Home Serverの場合、システムディスクにインストーラが2つのパーティションを作るので、AFTのページに従うと、7-8ジャンパショートではなく、パーティション作成後(すなわちインストール後)にWD Alignを実行する必要がある。


まずはWD10EACSを2台売って、WD20EARSを購入。

WD20EARSだけをSATAで接続後、WHSをインストール。インストール完了後にWD Alignを実行。

その後Windows Updateを実行したり、バックアップしたデータを共有フォルダに戻したりしたのだが、どうも動作が遅い。

WD10EADSをシステムディスクとして使っていた頃より確実にかなり遅い。


どうにも我慢できなくなって、Windows Home Server上でフォーマット⇒WD Align実行した状態でのCrystalDiskMarkの結果と、Windows 7でフォーマット直後のCrystalDiskMarkの結果を比べてみた。


CrystalDiskMarkスクリーンショットを取っていたのだが、Windows Home Server上で実行したCrystalDiskMarkがバージョン1.0だったので、一旦スクリーンショットを貼り付けてからやめた。
参考まで、シーケンシャル読み書きはほぼ同等だが、Windows Home Serverでフォーマットした方は、WD Align実行後でも512K Read/Writeと4K Read/Writeが遅い。Windows 7でフォーマットしたのと比較して4分の1ぐらいの数字

デスクトップの操作性も確実に悪化していて、共有フォルダにデータが何も無い状態でもメニューひとつ開くのにかなり待たされる。

WD AlignはXP以前のOSへの互換性は提供するが、性能はかなり落ちる、特にWHSのシステムドライブとして使うには致命的なほど性能が落ちると結論付けて、WD20EARSをWindows Home Serverのシステムディスクとして使うのは諦めた。

WD10EADSにインストール

メインPCに付いていた倉庫用WD10EACSをWD20EARSとデータ移行後、交換。

WD10EACSをWHSに取り付けて、必要なデータをWHSの共有フォルダからWD10EACSにコピー後、WHSに元々付いていたWD10EADSをシステムディスクとしてWHSを再インストール。

このとき、最初のWHSセットアップの時点ではHDDはIDEモードで接続する。

セットアップ終了後、Intel INF Updateをインストールしてから、デバイスマネージャでICH9Rのドライバを手動でAHCI用ドライバ(いわゆるF6インストール用のドライバ)に入れ替えてから、再起動、このときBIOSでAHCIに切り替えるとAHCIに切替完了。


うん、やっぱりWD10DEADSの方が速い。

一晩かけてメインPCにコピーしておいたデータをWHSの共有フォルダにコピー戻しして、おおよそ作業完了。

WHSiTunes 9.1をインストール

ちなみに・・・、iTunes 9.1をWindows Home Serverクリーンインストールしてみた。

(もちろんOrcaを使ってAppleMobileDeviceSupport.msiのLaunchConditionを"Drop Table"する)

iTunes Helperがインストールされない、という事象が発生した。
どうせiTunes HelperはiPodが接続されているかチェックして接続されていたらiTunesを起動する、という働きしかしない(らしい)ので、iTunesを起動した際にメッセージが表示されるのはうっとおしいが別に気にしない。

iPodServiceは何もしなくても普通に起動したが、OS再起動時は何度か起動失敗する。

iPodと同期はできているので、問題は無いでしょ。